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HTML Review Terminology

Root folder:
HTML:
Headings:
Tags:

element:
Block Element:
Inline Element:
CSS:
properties
DIV:

Browser:

local site:

remote site:
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Week 1 — Dreamweaver Interface and HTML / CSS Review

No matter your approach, hand coding with a program such as text wrangler or using a WYSIWYG editor
such as Dreamweaver, you always need to start with a clean folder structure.

1. Make a root folder on the desktop and name it HTML review root - your last name
2. Open Dreamweaver and go to File > New and select the HTML page type.

3. To experience your first taste of WYSIWYG goodness, choose HTML 5 from the doctype dropdown
and click Create
* Notice the doctype and meta charset declarations at the top of the page; no need to remember to
add them or to copy and paste the code from another doc.
Also notice the provided framework of HTML elements that every site has.
* The <head> element is for:

* The <body> element is for:

4. Change the page <title> to “Your Name - HTML Review”.

5. Save the new HTML file into your root folder. Of course we always name the first page of our website
.htm|

Root Folder Review

Of course we remember the key to a clean website is a clean root folder. Only store the files a user will
see in the root folder. As you work on the design of your website, keep the native .psd’s and other file
types in another folder, we'll refer to as “supportive”. Keeping things clean up-front will help you in the

long run. | also keep a “project folder” that will hold both my root and supportive folder to make sure
everything for the project is kept together.

Both of these folders

live happily in a Project
Folder.

The root folder contains
only site files.

All non-site files
are contained in a
supportive files folder.
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Exploring Dreamweaver

Setting up a new Dreamweaver “Site” to manage a root folder

Dreamweaver will keep track of our files for us and let us know if we are about to mess things up. The
only way to ensure this is to link the root folder into Dreamweaver through setting up a site. Everytime
you make a new website with Dreamweaver you need to start with this process. In addition, everytime you
want to work on your site after you logoff a computer at school you'll need to re-link your site to the new
workstation. If you are working on a site at home or on your laptop, once the link is specified it will stay.

The steps to linking a Dreamweaver “site” to an existing root folder

1. In Dreamweaver go to Site > New Site

2. Name your site (You can name it anything that makes sense to you).

3. By “Local site folder” click the folder icon to browse and find an existing root folder, or create a

new one.
4. Click “choose”
5. Click Save.

6. When the link is successful, Dreamweaver shows the contents
of your root folder in the Files panel.

Files Panel

Highlights include:

=

Assets | Files |

[ | HTML review | ¥ | [Local view [ ]

HnCI D E Y e A
Local Files - | Size | Type
w . Site - HTML r... Folder

"= index.html 1KB HTML Fi

Manage your site files (rename files, delete things, add folders, etc.) without leaving the coding

environment

Upload and synchronize your local site (on computer) with your remote site (on the web)
Automatically update all links on your site when you remove or rename a file (no need to recode)

Add a new folder to the site by
selecting the root folder in the
files panel and clicking the panel
drop down.

[ HTML review | =] [Local view

e O 6a@ R

Local Files & | Size

v [ site-HMLY...
o

index.html  1KB

| Modified
8/13/14 10:05 Al
8/13/14 10:05 Al

| Type
Folder
HTML File

Navigate to the File area and
choose New Folder.

A I 3

|@  Date:8/13/14 10:05 AM

Name the folder images.

File » New File 438N

Edit > New Folder NOEN

View > Open

Site >
Rename F2

Help Delete [Ex
Turn Off Read Only

Close Roll Back Page

Close Tab Group Comp ! ver
Preview in Browser >
Check Links tF8
Design Notes...

Reveal in Finder
I

Remember your naming convention best practices!

no spaces, no caps, no special characters; except a dash in some cases, why is this2

You still will need to add your media files into the root folder from the finder. Dreamweaver will then help
you to manage them from inside the application.
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1. Drag the “01 HTML Review Supportive” folder from the server to your desktop.
From the finder, add the “header.gif” file to the images folder of the root folder

add the tutorials.html file to the root (top level) of the folder structure

B L

Once you add files from the finder, you may need to hit the refresh button in the files panel to see
them in Deamweaver.

Design Workspace
1. Change your workspace to the design preset, it gives a few more Design - ED
WYSIWYG options than the default.

View options in Dreamweaver

Code View

This view will remind you a lot of Text Wrangler. Type code by hand, but take advantage of the shortcuts
dreamweaver has to offer.

Design/Live View
Good in theory but difficult to work in exclusively. To be safe, always preview and test your site in a web
browser. “But it looks right in Dreamweaver” is a statement | often hear, but does little to help your client.

Design view atfempts fo give you a visual preview of the site as you build it, but doesn’t display any
of the fancy CSS3 effects you may have added.

Live view actually renders a fairly accurate preview of your finished site but does sometimes have
some innacurracies.

Split View

In terms of designing and developing for the web, this is a nice compromise between form and function.
Use the code view to make HTML and CSS changes, while watching the design or live view to see if the
changes take effect. As long as you just use it as a quick visual test, this set-up works great.

Site Preview
Anytime you want to see your site in all of it’s glory, make sure to preview it in a browser.

Go to Iflle > Preview in browser or find the ® L0 o oy |
globe icon on the bottom of the screen and

. Preview in Safari.app N F12
!
choose the browser you'd like to test. R ratox app

Preview in Opera.app
Preview in Google Chrome.app

Edit Browser List...
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Insert Panel

Think structure. The insert panel is where you can “write” code without typing. Find what you want to
add, and click on the button. Dreamweaver will add the elements (and code) for you wherever you cursor
is placed. We spend a lot of time in the HTML options, but feel free to explore the others.

Interestingly, after some time, many designers find it more efficient to make changes directly in the code
rather than scrolling the insert panel provided by Dreamweaver. There is no right or wrong approach, so
do whatever is most comfortable for you.

CSS Designer Panel

Think Presentation. The CSS Designer panel is Dreamweaver’s solution to writing CSS visually. This
panel relies a lot on context sensitive selections, so what you have selected will impact the options you see
here. We'll use this panel together in a bit.

HTML Review

Even though What You See Is What You Get (WYSIWYG) editors such as Dreamweaver allow you to
design a page visually, good web designers know how to go into the HTML and fix problems, or add
code that Dreamweaver does not yet support. Luckily, you all are the latter who have come to appreciate
working solely in code.

e HTML is code that describes the structure of a page. It tells a browser things such as what is a
headline and what is a regular paragraph. HTML does not tell the browser how these structures
should look.

*  Go to any web site view the browser source to see the HTML that makes up the page. (Hint: you can
learn a lot by looking at the code of other people’s websites)

*  HTML files are very small. They download very quickly.

e HTML is universal. Every computer knows how to read HTML files.

*  Dreamweaver writes HTML code in the background as you click.

1. Inside your support folder is a file named “text.rtt” Open this file and copy (cmd+C) the text.
2. Paste (Cmd+V) the text inside the <body> element of the index.html| page (code view).

3. Save, then preview in a browser. Click the preview button or go to File > Preview in Browser >
Safari. Notice how the browser ignores the line breaks. This page needs help.
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4. Leave the Safari window open and go back to Dreamweaver and add the following HTML tags to the
content with the format dropdown, quick keys, or Insert Panel options that your instructor will show you

NOow.

5. Save the document. Go back to Safari and click the Refresh button. If you typed the tags right, your
page should look much better now. Why are there all of a sudden hard returns after the <p> and

<h1> tags?.

6. Go back to Dreamweaver and add the following tags, again using Dreamweaver’s WYSIWYG

options.

<h1>Welcome to HTML Review</h1>

<p>HTML, which stands for Hyper Text Markup Language, is the predominant
markup language for web pages. It provides a means to create structured
documents by denoting structural semantics for text such as headings,
paragraphs, lists etc as well as for links, quotes, and other items. It allows images
and objects to be embedded and can be used to create interactive forms. It is
written in the form of HTML elements consisting of “tags” surrounded by angle
brackets within the web page content. It can include Cascading Style Sheets (CSS)
to define the appearance and layout of text and other material. </p>

<p>To become an HTML coder you only need three things: a text editor, a
browser and a good tutorial. </p>

<p>Thank you for visiting our web site. Before you go, check out the tutorials
page!</p>

<p>This page is brought to you by Western Technical College.</p>

<p>HTML, which stands for <strong>Hyper Text Markup Language
</strong>, is the predominant markup language for web pages. It provides
a means to create structured documents by denoting structural semantics for
text such as headings, paragraphs, lists etc as well as for links, quotes, and
other items. It allows images and objects to be embedded and can be used to
create interactive forms. It is written in the form of HTML elements consisting of
“tags” surrounded by angle brackets within the web page content. It can include
Cascading Style Sheets (CSS) to define the appearance and layout of text and
other material. </p>

<p>To become an HTML coder you only need three things: </p>

<ul>
<li>a text editor </li>
<li>a browser </li>
<li>a good tutorial < /li>
</ul>

<p>Thank you for visiting our web site. <@m>Before you go, check out the
links page! </em> </p>
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7. Save the document. Go to Safari and click the Refresh button to see your changes.

8. Why don't the <em> and <strong> elements cause a line break?

9. The second paragraph contains a list. What makes a list different from a regular HTML element such
asan <H1>2

brackets within the web page content. It can include Cascading Style Sheets (CSS)
to define the appearance and layout of text and other material. </p>

<p>To become an HTML coder you only need three things: </p>

<ul>
<li>a text editor </li>
<li>a browser </li>
<li>a good tutorial</li>
</ul>

<p>Thank you for visiting our web site. <em>Before you go, check out the links
page! </em> </p>

10. Add hyperlinks to your document with your instructor:
These link tags include navigational paths to other documents. The first shows a relative path that
says, “Open the tutorials.html document from this same folder.” The second uses an absolute URL to
link to a different web site.

<p>Thank you for visiting our web site. <em>Before you go, check out the
<a href="tutorials.html” >links page! </a></em> </p>

<p>This page is brought to you by <a href="http://www.westerntc.edu’ >
Western Technical College. </a></p>

</body>

</html>

11. Save the document. Go to Safari and click the Refresh button to see your changes. Test the links.

Web Design ¢ 08-2015
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12. Add an image to your web page with your instructor:
This tag includes a resource path. The aftribute, sre="images/header.gif” says, “Go info the
‘images’ folder and get the ‘header.gif’ image.” This is another example of a relative path.

<html>

<head>
<title>HTML Primer< /title>
</head>

<body>
<img src="images/header.gif” >
<h1>Welcome to HTML Primer</h1>

<p>HTML, which stands for <strong>Hyper Text Markup Language</strong>,
is the predominant markup language for web pages. It provides a means to
create

13. Save the document. Go to Safari and click the Refresh button to see your web page with an image
header.

CSS Review

e (CSSis the code that describes what an element should look like, NOT the meaning of an element.
* Use an external stylesheet for optimal efficiency.
* Not all CSS rules are supported by every browser, test often.

Now that we are structurally sound, let’s add a little style. Use Dreamweaver’s CSS Designer panel to
define the properites for the <body> element.

Create an External Stylesheet

1. In Dreamweaver locate the CSS Designer panel.
In the sources areq, click the + icon to create a new css file.

Name you style sheet styles (the .css extension will be added automatically)

R

Browse to your root folder, and save the file there.

Web Design * 08-2015
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Style an element

1. Make sure styles.css is selected in the source area. This will ensure any new styles we create will be
added to that stylesheet.

2. Click the + icon in the selector area and type body. This enables us to start styling properties of the
<body> tag.

3. Look at the properties area. By default there is a little + — Properties
box called show set that is checked. Because we have L Show Set|
not set any properties, the box is blank. = =
|.3\c'c'mo_c'-:(."y | H |addvan’us |
If you know the property you want to change you can type
in in the box along with the corresponding value. +  Properties
= O = [ Show Set
4. otherwise uncheck Show Set to see a scrollable list of - n
what you can change. ot
5. click between source code and styles.css on the top- background-image
left of the document window to toggle between the HTML ur
and CSS code. gradient

6. with the body selector selected, find and change the
following values in the properties area:

body {
background-color: #91DEB5;
width: 760px;
margin: 0 auto;
font-family: Gotham, “Helvetica Neue”, Helvetica, Arial, sans-serif;

}

7. Look at the CSS code and notice how Dreamweaver has written the styles for you.

8. Save the document by going to File > Save ALL. This saves all open windows (both the HTML and
CSS). If you forgot to save one or the other the changes will not be reflected.

9. Go to Safari and click the Refresh button to see your web page with the added styling. (switch to LIVE
view within Dreamweaver and see changes on the fly if you'd like).

Review
To style elements you need to:

1. Create a styles.css stylesheet

2. Make sure styles.css is chosen as the source (CSS Designer Panel is context sensitive)
3. Add the selector you wish to style (make sure it's selected)
4

change the associated properties of that elelment.
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Add classes to an element

A class is a reusable style definition that let’s you change properties of certain elements as indicated in the

HTML.

A class is identified by a . (period) in front of the selector name. (ex: .highlight, . price). You can give
this class any name you'd like but make sure it talks about the meaning, and not a specific property. For
instance:

.blue is probably a bad selector name. What if we change the property to green? The style name
no longer makes sense.

.price is probably a good selector name. It doesn’t matter what color we decide to use, the price
is always the price.

so in the selector area:
1. click the +

2. start your class name with a period.
.highlight

3. change the following properites

.highlight {
background-color: #FDFC00;
font-weight: 600;
text-decoration: line-through;
border: thin solid #F80409;

4. If you tried to save and preview the page right now, you wouldn’t see any changes. Remember you
need to add the class to the HTML tag in order for it to work.

5. Highlight some text in the html

6. Inthe class dropdown of the properties panel, choose the class you'd like to apply.

m Format | Paragraph | Class | None IYl‘, e E Title |:|
B css ID [None [+]  Link | highlight Target | | =]
!
Document Title | html review - casper | Rename... D | |
Attach Style Sheet... |

Web Design ¢ 08-2015
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Assignment 1-A: Reaction Site

Read the following design article:

http://www.goodui.org/

Watch the following youtube video (let me know if you need any help turning on closed captioning)

https://www.youtube.com/watch?v=IsXEVQRaTX8

copy the reaction site root folder from the server, to the desktop

Link the reaction site root folder into Dreamweaver. (site > new site).

rename reaction.html to index.html

Open the index.html document from the files panel.

In Dreamweaver, replace the nonsense placeholder text with your thoughts on the articles.
Type/Apply the appropriate tags and preview your page in a browser as you go.

Use an external stylesheet for any CSS styling

test your site, including all links.

When your site looks great and works perfectly, change the name of the folder to “Your last name -
first initial - TA” (e.g. smithb-TA) and put the entire folder in the correct drop box on the server.

Web Design * 08-2015
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F—Page stays centered in the browser window (content width is the same as the header image). =14

Page ftitle

Em| file:///Users/casperp/Desktop/reaction%20site/reaction® A/ﬁﬂ//
Apple Reaction to the reading <"‘_
0 dpace
Wwesternsisas!
College

westernlogo.gif is in the images folder. |

THE QSSENTH\L EXPERIENCE

My thoughts on the HTMLS5 as Fast as Possible Video ~

Level 1 Heading |

The three most interesting revelations:

. insight 1 Level 3 Heading | title class to the article titles

- insigne3 #FF0004

« insight 3 Y
Make an unordered list | italic

Why I thought they were interesting

Lorem ipsum dolor sit amet, consectetur adipiscing oltt Mak thi bold
rutrum nisi. Nam porttitor nec libero sit amet cursus. Donec a congue enim, id dapibus nibh. Etiam egestas volutpat ake someining bo
risus, nec ultricies enim tempor ut. Praesent consequat nulla ac bibendum condimentum. Dol ctetur nisi |

mauris,

Make something italic |

My thoughts on the Goodui.org Article I

Level 1 Heading |

The five most interesting tips:

e tipl
. tip2 title class to the article titles
. Iip 3
. tip3 Make an unordered list | #FFO004
« tip3 T
italic
Why I thought they were interesting < ;! Level 3 Heading |

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas eu i
nisi. Nam porttitor nec libero sit amet cursus. Donec a congue enir
ultricies enim tempor ut. Praesent consequat nulla ac bibendu

m risus. Morbi et aliquam sapien, in rutrum
dapibus nibh. Etiam egestas volutpat risus, nec
ndimentum. Donec consectetur nisi mauris,

How they will effect my designs for the web

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas eu ipsum risus. Morbi et aliquam sapien, in rutrum
nisi. Nam porttitor nec libero sit amet cursus. Donec a congue enim, id dapibus nibh. Etiam egestas volutpat risus, nec
ultricies enim tempor ut. Praesent consequat nulla ac bibendum condimentum. Donec consectetur nisi manris

http://www.adobe.com/products/dreamweaver/ |

Check out the Adobe Dreamweaver software. <&

Click here to see class descriptions. | descriptions.html |
T

Email questions to you@youremail.com.

Research and find how to make an e-mail link.

Use your e-mail address.
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